Skip to content Skip to sidebar Skip to footer

Composer Error Your requirements could not be resolved to an installable set of packages

Ubuntu Composer Error

neon@neon:~/Documents/siml-master$ composer update

Loading composer repositories with package information

Warning from https://repo.packagist.org: Support for Composer 1 is deprecated and some packages will not be available. You should upgrade to Composer 2. See https://blog.packagist.com/deprecating-composer-1-support/

Updating dependencies (including require-dev)

Your requirements could not be resolved to an installable set of packages.



  Problem 1

    - Installation request for phpoffice/phpword ^0.18.2 -> satisfiable by phpoffice/phpword[0.18.2].

    - phpoffice/phpword 0.18.2 requires ext-xml * -> the requested PHP extension xml is missing from your system.

  Problem 2

    - codeigniter4/framework v4.1.5 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - codeigniter4/framework v4.1.4 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - codeigniter4/framework v4.1.3 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - codeigniter4/framework v4.1.2 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - codeigniter4/framework v4.1.1 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - codeigniter4/framework v4.1.0 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - codeigniter4/framework v4.0.5 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - codeigniter4/framework v4.0.4 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - codeigniter4/framework v4.0.3 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - codeigniter4/framework v4.0.2 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - codeigniter4/framework v4.0.1 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - codeigniter4/framework 4.0.0 requires ext-curl * -> the requested PHP extension curl is missing from your system.

    - Installation request for codeigniter4/framework ^4 -> satisfiable by codeigniter4/framework[4.0.0, v4.0.1, v4.0.2, v4.0.3, v4.0.4, v4.0.5, v4.1.0, v4.1.1, v4.1.2, v4.1.3, v4.1.4, v4.1.5].


  To enable extensions, verify that they are enabled in your .ini files:

    - /etc/php/7.4/cli/php.ini

    - /etc/php/7.4/cli/conf.d/10-opcache.ini

    - /etc/php/7.4/cli/conf.d/10-pdo.ini

    - /etc/php/7.4/cli/conf.d/20-calendar.ini

    - /etc/php/7.4/cli/conf.d/20-ctype.ini

    - /etc/php/7.4/cli/conf.d/20-exif.ini

    - /etc/php/7.4/cli/conf.d/20-ffi.ini

    - /etc/php/7.4/cli/conf.d/20-fileinfo.ini

    - /etc/php/7.4/cli/conf.d/20-ftp.ini

    - /etc/php/7.4/cli/conf.d/20-gettext.ini

    - /etc/php/7.4/cli/conf.d/20-iconv.ini

    - /etc/php/7.4/cli/conf.d/20-json.ini

    - /etc/php/7.4/cli/conf.d/20-mbstring.ini

    - /etc/php/7.4/cli/conf.d/20-phar.ini

    - /etc/php/7.4/cli/conf.d/20-posix.ini

    - /etc/php/7.4/cli/conf.d/20-readline.ini

    - /etc/php/7.4/cli/conf.d/20-shmop.ini

    - /etc/php/7.4/cli/conf.d/20-sockets.ini

    - /etc/php/7.4/cli/conf.d/20-sysvmsg.ini

    - /etc/php/7.4/cli/conf.d/20-sysvsem.ini

    - /etc/php/7.4/cli/conf.d/20-sysvshm.ini

    - /etc/php/7.4/cli/conf.d/20-tokenizer.ini

  You can also run `php --ini` inside terminal to see which files are used by PHP in CLI mode.


How to Fix This

Open your terminal and use this command:

sudo apt install php-xml
sudo apt install php-curl
sudo apt install php-intl
sudo apt install php-gd
sudo apt install php-zip

Post a Comment for "Composer Error Your requirements could not be resolved to an installable set of packages"